有無 ching 收到 31 台

如題

回復 1# chancho
我的沒有問題? 你有問題? 是甚麼tuner ?

TOP

本帖最後由 chancho 於 2014-1-15 19:56 編輯

i added "T 802000000 ..." into the initial file, but scan gave me an invalid paramenter error.

TOP

i added "T 802000000 ..." into the initial file, but scan gave me an invalid paramenter error.

TOP

本帖最後由 ksng 於 2014-1-15 18:05 編輯

回復 4# chancho
what's the tuner chip or what's the model of your adapter?

Back in 2012 when RTHK first conducted its digital TV testing, I found that my Mygica 8558pro could not tune to the RTHK frequency. After some studying I found it was due to the max. frequency as defined in the altobeam driver not high enough. I modified it and it works. As far as I can remember, I've submitted a patch to the v4l-dvb project team, but I can't find any trace now in my mailbox. Anyway I found the max. freq in newer kernels been set correctly so the fix for altobeam must have gone through.

Below's part of the altobeam driver in question:

    static struct dvb_frontend_ops atbm8830_ops = {
        .info = {
                .name = "AltoBeam ATBM8830/8831 DMB-TH",
                .type = FE_OFDM,
                .frequency_min = 474000000,
                .frequency_max = 858000000,   <--- it was less than 800MHz before
                .frequency_stepsize = 10000,
                .caps =
                        FE_CAN_FEC_AUTO |
                        FE_CAN_QAM_AUTO |
                        FE_CAN_TRANSMISSION_MODE_AUTO |
                        FE_CAN_GUARD_INTERVAL_AUTO
        },

TOP

本帖最後由 chancho 於 2014-1-15 20:11 編輯

here is the initial file
  1. # Hong Kong (DMB-TH)
  2. # T freq bw fec_hi fec_lo mod transmission-mode guard-interval hierarchy

  3. # TVB (band 35)
  4. T 586000000 8MHz AUTO NONE QAM64 8k 1/32 NONE
  5. # ATV (band 37)
  6. T 602000000 8MHz AUTO NONE QAM64 8k 1/32 NONE

  7. # Simulcast (band 22)
  8. T 482000000 8MHz AUTO NONE QAM64 8k 1/32 NONE
  9. # Simulcast (band 30)
  10. T 546000000 8MHz AUTO NONE QAM64 8k 1/32 NONE
  11. # Simulcast (band 32)
  12. T 562000000 8MHz AUTO NONE QAM64 8k 1/32 NONE
  13. # Simulcast (band 40)
  14. T 628000000 8MHz AUTO NONE QAM64 8k 1/32 NONE
  15. # Simulcast (band 43)
  16. #T 650000000 8MHz AUTO NONE QAM64 8k 1/32 NONE
  17. T 802000000 8MHz AUTO NONE QAM64 8k 1/32 NONE
複製代碼
here is the error message :
  1. >>> tune to: 628000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE (tuning failed)
  2. WARNING: >>> tuning failed!!!
  3. >>> tune to: 802000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE
  4. __tune_to_transponder:1910: ERROR: Setting frontend parameters failed: 22 Invalid argument
  5. >>> tune to: 802000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE
  6. __tune_to_transponder:1910: ERROR: Setting frontend parameters failed: 22 Invalid argument
複製代碼
your code is about the same as the updated driver.

TOP

回復 6# chancho
when tuning to 802Mhz, you got error "invalid parameter" which is different from what you got when tuning to 628MHz. It probably means 802 is outside the valid range as coded in the driver.

Different tuners/frontends have different drivers. The code I pasted is only for altobeam. The "max freq" parameters for other tuners/frontends may be too low, making 802Mhz invalid.

Hence I need to know your dmbth adapter model before I can check the source code. Also what kernel version are you running. If you're running too old a kernel, say older than 2 years, then even the altobeam should have problem, because that was before I submitted the patch to the v4l-dvb team.

TOP

it mygica d689, driver :  atbm8830

TOP

ooops! Just found there's problem in for the tuner MAX2165 even for the latest kernel. In the file drivers/media/common/tuners/max2165.c, I can see:

static const struct dvb_tuner_ops max2165_tuner_ops = {
         .info = {
                 .name           = "Maxim MAX2165",
                 .frequency_min  = 470000000,
                 .frequency_max  = 780000000,
                 .frequency_step =     50000,
         },

frequency_max should be set to, say, 868000000.

I'll try to submit a patch to v4l-dvb. In the meantime, anyone using this tuner chip will need to compile own v4l-dvb driver.

TOP

you better check other frontend to see if they need to increase the max freq.

TOP